Die mem-Verknüpfung

  • Hallo,


    über dieses Thema ist schon einiges geschrieben worden. Meist ist es irgendwo in einem "Hilfesuche-Thread", und man findet es schwer wieder. Deshalb mache ich hier dazu doch nochmal ein eigenes Thema auf, auch auf Anregung von Andreas-PZ hin. :)


    Andreas empfahl mir letztens diese Verknüpfung: D:\MSTS\train.exe -mem:2048 -timeacceleration -fsaa -anisotropic -nofiltercab
    Dies klappte bei "normalen" Strecken und "normalen" Aufgaben mit meinem PC wunderbar, z.B. Aufgabe "Hin und her" auf PT35.


    Wo es nicht ging, das war die Aufgabe "Ex157" auf PT35 und die Trat 321 V20 im Bereich Prag.
    Beim Ex157 vermute ich, daß sich einmal der Schneefall negativ auswirkt. Außerdem fahre ich in dieser Aufgabe Spielerlok und alle KI 250 mit BR 243 HIBU Sound, welcher die Hardware doch ordentlich beansprucht.


    Ich habe nunmehr folgende Verknüpfung in Gebrauch: D:\MSTS\train.exe -mem:1024 -timeacceleration
    Die 1024 ist beabsichtigt, da sich herausgestellt hat, daß er damit tatsächlich besser läuft als mit 2048.


    Grüße Cris

  • Ich habe nunmehr folgende Verknüpfung in Gebrauch: D:\MSTS\train.exe -mem:1024 -timeacceleration
    Die 1024 ist beabsichtigt, da sich herausgestellt hat, daß er damit tatsächlich besser läuft als mit 2048.

    Das deckt sich genau mit meinen Erfahrungen. Ich fahre auch mit dieser Einstellung und habe seitdem fast keine Probleme mehr. Mit mem: 2048 kam es recht häufig zum "einfrieren" des Spiels. fsaa -anisotropic halte ich für überflüssig, mit den entsprechenden Einstellungen der GraKa habe ich auch so eine sehr gute Optik.
    -nofiltercab, muß ich zugeben, kenne ich nicht.


    Gruß trainaholic

  • Hallo,
    ich habe nur die mem-Verknüpfung und die habe ich auf 2560 gesetzt. Ich habe damit sehr gute Erfahrungen vorallem auf der Rübelandbahn, aber auch anderen Strecken mit hoher Objektdichte gemacht. Außerdem benutze ich das Programm "nHancer" was auch noch mal kräftig was bringt, hab ich besonders beim neuen Werratal gemerkt.


    Die Auswirkungen dieser Einstellungen werden aber sicher von der Hardware beeinflusst. Und welche Rolle spielt das Betriebssystem?


    Grüße vom Freckel

  • Guten Abend "Füchse" Allen ein gesundes und erfolgereiches Jahr 2012. Richtig trainaholic die Eintragung -fsaa -anisotropic- kann aus der mem Funktion herausgenommen werden, wußte es auch nicht, aber unser Norbert schrieb mir heute das diese Eintragung gegenwärtig nichts bringt. -nofiltercab steht damit das Gittermuster im Cab beim Starten über die Train exe nicht zu sehen ist. Ich habe in die mem Funktion 3000 eingegeben und es funktioniert ohne Probleme, muß aber beim nutzen des TS den WLAN Sender deaktivieren, da mir im Vorfeld der TS ein paar mal abstürtzte . Ich habe aber keine Erfahrungen lieber Cris mit den der Strecke Trat 321.


    Maik was beinhaltet das Programm "nHancer " ?


    Gruß Andreas

  • Hallo Andreas,


    ich bin immer noch der Thomas :lol: , hier Zitat von der Chip-Download Seite:


    "Das kostenlose nHancer bietet Einstellungs-Möglichkeiten und Profil-Verwaltung für nVidia-Grafikkarten.

    nHancer bietet eine aufgeräumte Oberfläche, über die Sie die Einstellungen Ihres Nvidia-Forceware-Teibers verändern können."


    Damit lassen sich alle Graphik Einstellungen der Karte für jedes Spiel speziell einstellen, die dann immer mit Start des Spiels (TS) gültig werden. Verlangt Microsoft .NET Framework 3.5.


    Gruß vom Freckel

  • Die mem Verknüpfung....
    Um mal mit Mythen aufzuräumen: Alles was man mehr als 1024MB eingibt wird nicht akzeptiert. Stattdessen werden immer 512 genommen. Es kann auf einigen Systemen nun vorkommen das tatsächlich dieser ungültige Wert besser läuft als 1024.. das heißt aber nur das auf diesen Systemen 512 generell besser läuft als 1024. Warum? Ganz einfach. zur Verfügung gestellter Speicher muß natürlich auch verwaltet werden. Und genau da fallen Syteme mit wenig Board und CPU-Cache aus. Die große Menge Speicher, kann dann nicht im Cache verwaltet werden, sodas eine freigabe von 512 besser läuft als eine freigabe von 1024....
    Ich selbst benutze im ts 512 und im Edi 1024 hat sich so bewährt...
    Baertram

    Nur weil es in den sechzigern kaum Farbfotos gab - heißt das nicht das die Zeit farblos war.

  • Verzeihung Thomas wegen dem falschen Namen, hatte meine Gedanken noch beim letzten Testbericht.


    Was du schreibst Baertram ist sehr interessant und für mich völlig neu, da ich zum Beispiel in den Installationshinweisen der SOB und von GR-10 Jahre immer den Hinweis las, bei 4 GB Arbeitsspeicher 2048 in den mem Pfad einzugeben. Auf jeden Fall werde ich es heute Abend probieren und wie du empfohlen hast 1024 eingeben. Schauen wir mal.


    Gruß Andreas

  • Guten Abend Füchse. Wie schon angedeutet bin ich eine Teil Strecke mit einer mem Eintragung von 1024 im Führerstand, mit der Außenansicht und mit 2048 im Edi mit den gleichen Einstellungen auf PT 36 , Nacht m, Winter , Freie Strecke gefahren. Habe mir Urzeit und FPS genau aufgeschrieben und kaum Unterschiede bemerkt. Ich denke im Grenzbereich zum Beispiel SOB und große Bahnhöfe sind die Ergebnisse etwas objektiver.


    Unterstreiche natürlich Roberts Frage nach dem Betriebssystem und dem Arbeitsspeicher. Gruß Andreas

  • zitat: Unterstreiche natürlich Roberts Frage nach dem Betriebssystem und dem Arbeitsspeicher. Gruß Andreas


    hallo füchse,
    für mich wäre mal interessant zu wissen, wie die fps allgemein ausschauen unter:
    win7 ( 64 bit )
    2 kern / 4 kern prozessor über 3 ghz
    mehr als 2 gb ddr3 ram ( 1066 / 1333 mhz )


    das ganze gern bei der " neuen rollbahn / bahnhof münster " unter db tracks....
    mit meinen system muss ich die sichtweite auf 500m/750m einstellen, dass die fps nicht in den keller gehen....


    grüße chris

  • Hallo,


    "C:\Program Files (x86)\Microsoft Games\Train Simulator\launcher.exe" -rungame

    habe jetzt die kritische Trat 321 - Aufgabe mit dieser Einstellung getestet, 1x 1:1 und 1x mem 1024 hinzugefügt.


    Ergebnis bei beiden:
    - Aufgabe stürzt bereits nach 1/3 der Strecke ab wie mit meinen Einstellungen
    - ich habe 4 FPS weniger
    :(


    Aber einen Versuch war´s wert!


    Grüße Cris

  • Guten Abend Cris, mit welcher Einstellung der mem Funktion kommst du über diese kritischen Bereiche?


    Gruß Chris mit h meine PC Parameter kennst du Dank deiner und Frank seiner Empfehlung nutze ich die ATI 6670 . Habe den CCC mit den neusten Treibern auf maximale Einstellung, habe im TS alles auf Maximum, aber ohne Schatten. Hatte noch nie eine FPS unter 14 ( außer eine Sekunde beim Nachladen) Bin aber bisher nur normale Deluxe Strecken mit DB-Tracks gefahren. Gruß Andreas

  • Guten Tag zusammen,


    als stiller Mitleser habe ich aufmerksam diesen Thread verfolgt. Auch ich hatte, weil genügend Rechenleistung vorhanden, "2.048" in Gebrauch, konnte aber nicht wirklich Unterschiede zu "1.024" feststellen. Aktuell teste ich eine größere Aufgabenserie im dichten Schneefall und fahre - wie immer - mit höchsten Einstellungen und bestmöglichem Rollmaterial. Seit Jahren setze ich auf Nvidia und deren eigener, jeder Anwendung individuell anpassbarer Einstellungen. Bei Fahrten im Führerstand habe ich kontinuierlich 57 Fps. Nur in der Außenansicht (Taste 4) sackt diese Rate auf 27 - 21 ab. Der Simulationseindruck bleibt aber immer noch flüssig.


    In meiner aktiven Zeit im GR-Forum hat man sich mal ausgibig mit dem Thema Grafikkarteneinstellungen befaßt. Bis heute fahre ich noch mit den damals entwickelten Einstellungen für den MSTS. Wer Interesse hat, bitte mal nachfolgenden Link anklicken und zu Beitrag 84 scrollen. Grafikkartenproblem nVidia

  • Guten Abend Freunde, basierend auf meine ATI Grafka ist es bei mir komischer Weise es anderst wie bei Ostseestern, Ich habe bei Taste 2 & 3 die im Vergleich geringste FPS, im Führerstand Mittelwert und über Taste 4 die Beste Grafik. Bei allen neuern BSI Add- ON Habe ich auf freier Strecke eine etwas schwächere FPS als in den Bahnhöfen. Die moderne Rollbahn klammere ich aus.


    Aber das hilft unseren Cris nicht, bei der Lösung seines Problems. Cris ich glaube nicht das es an deiner Grafka und an deinen PC liegt das der TS abschmiert. Ich vermute es hat mit der Streckensituation zu tun. Ich hatte es einnmal bei einer Augfgabe auf meinen alten Rechner auf der SOB. Habe alle Einstellungen auf minimal gesetzt. Taste 1 eingestellt , abgespeichert, neu geladen, die Sicht im Cab nach rechts gestellt und 2- 3 Minuten so gefahren. Das half und ich konnte die Aufgabe mit normalen Einstellungen weiter fahren. Icfh denke so etwas lieber Cris hast du auch schon probiert.


    Andreas